Last tablet update chrashes app


like topic said:

My Fire HD10 did a update last night, since that I am not able to open the homehabit app (last beta installed).

App starts and closes after 1-2 seconds. It is not fully closed, it is still in last opened apps available, but I can’t use it.

@Boogieman Thank you for the bug report!
Would you be able to submit crash report logs? it should suggest it automatically after 2 crashes.

Can’t submit a crash report.

Because the app doesn’t crash. It’s still open in the recent apps, but I can’t use it…

@Boogieman can you describe what you see after 1-2 seconds after the app open?

Also, what is the Fire OS version you have on HD10?

Here’s a movie I made


It’s FireOS (636559920)

Can you try one thing: turn off internet on device (wifi off or airplane mode) and start the app and see if it stops?

Same behaviour in airplane mode

Do you know when the app was last updated prior to last night? Was it something around Jan 5 or earlier than that?

New build has been pushed out Beta 20 (4711) that rolls back some changes from the last few days. Let me know if that fixes it.


There is still no update available for me

@Boogieman Oh, that’s unexpected. Just to clarify, are you enrolled into “beta” releases inside Play Store on that device?

Yes I am.
On my phone (oneplus 6) its available. But on my fireHD10 with the Problem not.

If you can try completely closing Play Store, sometimes that helps.
In the mean time, I will push out build again, maybe that will make update available.

Tried this before…

Am I the only one using a Fire tablet facing this problem?

I am using a oneplus 6, a lenovo tab and a samsung tablet. None of them having a problem and they work like they should.
Only the FireHD 10 having this issues. But this one is the wall mounted :joy:

Unfortunately, it does seem like that. Have Fire 10 on the same FireOS version wall mounted myself, and it works without issues :expressionless:

New build Beta 20 (4712) is rolling out. It should be available in the store within several hours, so please let me know if you still don’t see update after that.

If you can check one thing, what is the version of the Play Store app on Fire device?

Playstore shows

Version 17.9.19-all 285457741


New homehabit 4712 installed, but same behaviour :disappointed_relieved:


Don’t know why, but now homehabit started in safemode and I was able to submit a crash log.

Hope that will help you