Homehabit won't update

I was running b18 and got the issue that after some time most instances would not update fom HA. Eg the motion sensor wouldn’t switch to “detected” or the unifi presence detection would show “away” even though you were home. And other stuff.
Upgraded to b19 today, and now i got the issue that it doesn’t work at all. NONE of the sensors get’s updated, and all show initial state. Rebooted HA and Homehabit several times but it still is that way. I also went through setup again: Connection to HA webfrontend and authentication works, but no sensos show up.
Any idea how to debug??

@izeman There was an issue with HA date parsing on b19, so none of the components were working properly. New build has been pushed out just 5 minutes ago, should be available in your Play Store shortly.
This most likely will not fix the issue you had in b18, so if you experience that on latest b19, let me know. Thanks!

@igor: Thanks for the new update. Everything seems to work great now.
Sometime LIVE Video shows something about wrong video format or such, but it’s all working fine.
I also love the new stuff you added like info about last motion sensor activity. Maybe a little more contrast would be fine. It’s very hard to read. Light grey background with a little lighter grey font.

Thanks for let me know.

You mean live video that works generally sometimes shows wrong video format error?

Can you make a screenshot of how it looks for you?

Those are screenshots of my setup. I also captured one of the “video format errors”.
I guess the disconnects from HA and non updates from HA are caused by the video. This seems to use a lot of CPU/RAM and makes the app unresponsive. I also received this “wait/close” message which i haven’t seen before.
This is a 5 year old Nexus7. Really slow … Probably outdated.


I cannot really help with your problem but I would like to know how the timer inside of the Sensor widgets are configured. I have tried this with openHAB2 plattform but I havent found an parameter to configure this. It would be great if you could describe the configuration for me.

best regards René

@rene54321 in the latest pre-release version (Beta 19), there is a bindable Last Update Time property that accepts OH DateTime items.


how is it possible to use pre-release beta? Is this one also available from the PlayStore?

best regards René

@rene54321 yes, you would need to subscribe to beta channel in the Play Store. Those versions are released frequently, sometime daily, but can be unstable. More info on how to subscribe in “Get beta versions of apps” section on this Google Help page.

@igor are those screenshots helpful? Or do you need others? I now setup another tablet (old amazon fire) and deactivated camera on one of them to see if it makes a difference.

@izeman yes, those are good. Thanks for posting! Not sure yet why the app freezes with cameras. There was another report about similar problem. Will update after further investigation.

I now can confirm that the camera causes these hangs/non updating/loosing connection issues. I have two Tablet. Both very old. One an Amazon Fire, the other Nexus7. Both built at the same time, but the Fire seems to be a bit more powerful or has more memory?!

I run the same config on both, activate the camera widget and the next morning (or so) the Nexus hangs. Shows correct time, but the camera picture is frozen and non of the icons is up to date, no switches can be activated. The Fire still runs fine.

Then I remove the camera widget and re-run the test, and the Nexus runs fine all the time for several days. Re-activate camera, and it’s “dead” the next morning/afternoon.

It also seems the the Fire is much more responsive, especially when adding new widgets. The Nexus is quite laggy, and shows these “habitat is not responding” messages when adding camera widget.

Hope that helps. If you need some dump or something please let me know.

@izeman Thanks for the info! Just to confirm, you run camera widget on a snapshot interval and not on live video?

That doesn’t matter imho. It may be better to directly access the video from the camera instead of zoneminder, but I don’t think so, and I don’t have direct video included in homeassistant.

@izeman not sure if my question was clear. I want to understand what properties configured for camera widget to know what type of connection widget makes. Which properties do you have set in widget config: Video URL, Snapshot URL or both?

I see. I used the snaphot in pre17 and I now use video url and live video now.
But the problem was there some weeks(2mo?) ago, but I couldn’t nail it down to the video widget.