Google calendar not working

I’m not sure why I can’t add it. It was working fine before. I checked for updates just in case. I disabled and enabled it. Deleted it and re added it and still nothing. :cry::cry:15755206991701489738098408616939|375x500

Can you try creating new widget and going through “select item” flow to see if anything from Google Calendar available there?

Tried creating a new widget in different page and nothing was showing after selecting the calendar widget. Also tried not doing “explore widgets” and go straight to list of items and it wasn’t there. Before it showed up right at the top. Weird. I will turn off and turn on device later on. But if there is anything I can try let me know.

Any Google Calendar items were available before selecting calendar widget?


Do you know if anything changed between now and time it was working last, like new calendar in Google Calendar or something like that?
Also, can you tell me what is the device model and OS?

Nothing that I can think of. I mean. I get the email from Google telling me homehabit is accessing my calendar. So I know it’s making the connection. The only reason I noticed was because I added an event and wanted to make sure it was visible. I’m on a Nexus 7. OS is Android 6.0.1 I think but I will confirm later at home. I’m at work now. :disappointed:

It is Android 6.0.1 on a Nexus 7. I deleted the Google calendar connection and restarted the tablet. For the moment I am using a dakboard url for weather and calendar. And will try to re add it later as it was too late yester for me to continue messing with it.

Ok something weird happened. I uninstalled homehabit and reinstalled it. Upon opening it, the layout autopopulated to what it was before, and the calendar worked for a half a second. And then disappeared. And the issue resumed. I did the reinstalling twice and same thing happened both times.