Disconnected from Home Assistant. Trying to reconnect

HH was working flawlessly until a few weeks ago. Now it constantly says “Disconnected from Home Assistant. Trying to reconnect.” The only way it will work is if I close HH and reopen the app. Then it will work for about 20 minutes or so, until the next time I wake HH and the error will be there again.

The Home Assistant log shows the following error (the ip address in the error is my Galaxy Tab with HH):
“Login attempt or request with invalid authentication from ( Requested URL: ‘/api/’. (okhttp/3.14.9)”

Picture of the error on HH is here:
Google Photos

Any help would be appreciated.

@Michael_S What is the Home Assistant version?

Hello friends, I have a problem with my Home Habit panel, I have it installed on an android tablet, after a while it starts to disconnect and connect to the Hubitat hub, therefore it stops working, and after 24 hours it disconnects for full Hub Hubitat, in that case I have to close the app and open it.

74 / 5.000

Resultados de traducción

Resultado de traducción


I have tried with version 33 and 38 and it does the same. My hub is a Hubitat C7

Any idea of what could be happening, this dashboard is the one that best suits what I need,


I can confirm the same issue as @Michael_S.

Running HomeAssistant 2023.4.4 OS9.5 on a Raspberry Pi 4.
Getting the same error in the logs. (And annoying notifications)

1 Like

Hopefully Igor will answer me, I’m interested in this board and its paid version. While I was testing on my Hubitat I created a rule in RM that would ping my board every 1 second, this got better but it still keeps disconnecting from time to time.

@igor @Michael_S

@ccsnano This topic is specific to issue with Home Assistant integration. I did answer in the other thread about Hubitat.

I managed to solve my issue. A very simple one. I had a conflict on my internal network, and both the adroid tablet and some other device was fighting over the same IP-adress. Some static IP:s later we were back online.

Sorry for a dumb question! :blush:

I finally resolved this issue as well by using Home Assistant’s external Nabu Casa address rather than my network’s internal LAN address. When I first set HomeHabit up I was using the external address, then it had intermittent problems connecting so Igor recommended always using the local LAN address. After having this latest issue, I went back to the external address and so far so good. Wish I knew what changed and why I can’t use the LAN address anymore.

BTW @igor you had asked what version I am using but I was out of town when you asked. My HomeHabit ver is 38.9 (5239). My Home Assistant ver is 2023.3.6. Hope that helps.

1 Like