Camera widget ignores Snapshot Interval

I have the Camera widget bound to a Snapshot URL set with a Snapshot Interval of 60 seconds… But it always refreshes after 10 seconds???

@TommySharp is the seconds counter shows refresh every 10 seconds or just image changes?

Refresh counter counts up to 9 and then image reloads…

Does it happen for more than one widget, if you have multiple camera widgets?
Also, did you create/edit widget in the app or through remote config?

Interval property is working generally, so I’m just trying to figure out what could be different in this case.

Yeah happens for all 3 cameras on my main dashboard page… All added through app…

Fwiw, I just tried knocking one of my cameras down to snapshot only and 60 seconds on HH 4773,but it happily ticks past 10 seconds here, so no recreate.

@TommySharp If you are have Remote Config enabled, can you copy JSON for that widget?

This is the JSON for one of the cameras… I did notice that if I tap the camera to open full screen then it does only refresh every 60 seconds…

					"type": "camera",
					"position": {
						"x": 10,
						"y": 4,
						"width": 2,
						"height": 3
					"properties": {
						"label": "Garage",
						"video-uri": "",
						"snapshot": {
							"binding": "xy5umcspjegk1un7hzhjbtibv.SecCam3_URL#image.uri"
						"snapshot-image": null,
						"snapshot-interval": "60s",
						"scaling": "crop",
						"rotation": 0

@TommySharp when camera refreshes every 10 seconds, are images changing from current one directly to updated one or you briefly see image disappearing?

@TommySharp I’m trying to do something similar on my HomeHabit dashboard. I have a few Hikvision IP cameras on my network that I want to display. I’m connected to a Hubitat Elevation hub (not Home Assistant). I can’t enter the direct camera snapshot URL in HomeHabit since it requires me to bind to an item, but how did you create the item on your hub in the first place?

Do I need to create a virtual or real device on my Hub to bind to, or can I enter that url directly in the HomeHabit JSON config? (referring to your screenshot here: New camera popup not working)

@Mark do you have Hikvision cameras connected to Hubitat in some way?

No not yet, I’m working on that as well. I know that’s probably required before linking to it in HomeHabit but that’s proving to be much more difficult than I thought. I wanted to see if there were any workarounds or ways to access a local camera directly without binding to a hub device.

Cameras actually haven’t been tested with Hubitat integration yet, so it might still not work as is. Let me check on that as well.

I had to create a string item in OpenHAB and a rule that populates it with the URL of the image.

@igor Understood, thanks! I’ve just started configuring my Hubitat (transitioning from a Vera) and I’m not sure if I can even add cameras to it. But here are the two working options that I’ve tested out in the meantime:

  1. Place a camera widget and in the config editor manually change the “Video URI” property to the RTSP address of the camera. In my tests this works for up to 3 cameras on a page, but if you add a 4th camera they all stop working. This doesn’t really surprise me since its trying to simultaneously display 4 live video streams.
  2. Use the web widget and type in the snapshot url of the camera as the address, and set the refresh interval accordingly.

The web widget option works great except that it doesn’t blow up fullscreen when you tap on it like it would for a camera widget. Ideally I’d love to be able to manually type in the snapshot url in the camera widget so that I can get the full screen popup. Having the full rtsp live streams running on my wall tablet 24/7 also seems like overkill, so I’d rather just use the images with a refresh interval.

@TommySharp That’s pretty much what I was trying to do, but I don’t think I can create string items in Hubitat like you can in OpenHAB.

I uninstalled Homehabit and re-installed… Restored my json file and the images now seem to be reloading after the proper configured 60 seconds now…

There was a fix to camera reload issue in the latest build (camera image would fully disappear for a short period of time), but that issue usually happened once in a minute or so.
So maybe that also fixed it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.