Camera snapshot not working


I have the latest version of HomeHabit.

I use the RTSP integration, and when I use the snapshot URL, I get a file format error.

The URL (http://IP/cgi-bin/snapshot.cgi) works correclty in a web browser.

The video URL works correclty, the issue only concerns the snapshot.

Any idea?


@Samuel_AN Can you restart the app, make sure that snapshot error happens, and upload debug logs from the Support screen right after that?

Done right now !

I thought this might be an authentication issue (not passing credentials correctly), but it seems to work for similar use case in my testing, so not sure what is the issue yet.
What is the model of the camera?
Also, can you confirm that URL works in different browser or incognito? Just to make sure that browser is not caching session or anything.

The camera is a DAHUA IPC-HDBW

I just tried using an other web browser (edge for instance, which I never use), and it works simply with the following address:


Which does not work in HH.

PS, for the video URL I pass the credential in the same way (the end of the URL is different), and it works.

I see in the logs that there is a port number in the URL. Can you remove it for snapshot URL, so it just uses default. That port is for RTSP, so I’m wondering if that could cause issues, while browser might do something differently.

Hi Igor,

Thanks for your answer,

I tried to remove the port, but that does not work (I have tried with port 80 and without specifying the port number)

Hi @igor

Any hint to solve my problem? do you have already encountered this on other installation?

Thanks !

@Samuel_AN Nothing new yet. I don’t have that one or similar camera models to test right now, so not sure what to suggest. Snapshot is rarely a problem, most users have issues with video streams.
By any chance, is this camera accessible outside of your private network (duckdns or anything similar)?