Anyone used Amcrest/Dahua rtsp integration?

Bit of a long shot, but I’ve just setup the Amcrest AD110 doorbell camera.
Its working ok through Home Assistant, but would be nice to get the stream direct by using the HH RTSP integration. I can’t get it to work though.

I know the snapshot url is correct, as I can copy and paste it into the browser and it works

I’m less confident on the rtsp stream, but have tried everything google can provide, and still I get “image format error”. I dont current have an rtsp app to test it with outside of HH, but will get something setup for that soon. (The stream does work fine in another app, but it auto detects the camera).

  • rtsp example, Amcrest page suggests: rtsp://admin:password@ip:554/cam/realmonitor?channel=1&subtype=0&authbasic=64

@thisisdavidbell Can you confirm that you have Camera streaming (legacy) feature disabled in HomeHabit Labs?

Yup, disabled.

Can you try connecting again and upload debug logs after that?

Uploaded. Thanks.

@igor I don’t suppose you came to any conclusions on this? Sorry to ask, but Im thinking about returning the camera, so wanted to check with you first.


  • TinyCam Pro app works flawlessly, showing a truly live video at all times.
  • Official Amcrest app works fine.
  • Home Assistant LoveLace ui displaying the camera through HA starts off ok but gets seconds out of sync pretty quickly, and sometimes errors and stops updating.
  • Home Habit displaying camera widget from HA is 15 seconds behind permanently I think on live view (but rarely stops updating), and gives Image error when set to update every X seconds.
  • Home Habit web widget works fine displaying a snapshot url for the camera itself updating every 10 seconds
  • Home Habit rtsp integration fails as described above - never displaying anything.

As you can tell, none of the HA/HH options are usable for a doorbell camera on a dashboard beside the front door.

@thisisdavidbell There wasn’t anything certain from the logs, but I only saw snapshot errors in there. Did you also have stream connected and tried opening it before uploading?
Can you try removing snapshot from widget config and just try opening the live stream, and upload logs again?

Thanks for the reply.
I was never quite sure whether the camera widget needed both entries (which it seemed to add by default in most cases) or just 1 of them.
I just removed the snapshot entry, and for the last couple of minutes the stream is showing a live image (regardless of settings), just over a second behind Tiny Cam Pro, and without any errors yet.
I’ll keep an eye on it over the next day. Thanks.

Yes, for live streaming - stream property is required.
Snapshot only required if you don’t want to have live stream all the time. Otherwise, it will live stream regardless of other properties.
If only snapshot is added, opening live view will try to “simulate” live streaming by continuously refreshing the snapshot image. That’s to workaround some smart home system that don’t provide the live stream.

I’ve updated new logs. The widget is now frozen. Not showing moving video. It seems update about every 2 minutes, but only to a new “snapshot”, its not showing a live video. Note snapshot is not configured, only the video url.

Note, if I force the widgets to reload, by bringing up the settings menu and closing it, or coming out the app and back in, it returns to a live video stream without issues. I have seen this twice now, so I presume it is just slowly going wrong.

Okay, there nothing would be in the logs in this case, since such delayed lag would come from the video decoder itself.
I will run long-term streaming tests again and see the results. I don’t have armcrest camera right now for testing, but will try other rtsp.

1 Like

FWIW, I have found that if I refresh HH (Im using tasker to to load a diff app and then HH again) every 15 minutes, I often see the rtsp widget frozen. If I refresh HH every 10 minutes, I have gone 48 hours without ever catching it frozen.

Update on long-term stream testing - after a 24 hour streaming period with 2 active live RTSP cameras, there was practically no delay (around half a second delay, but it was the same at the start of the testing period).
I don’t have Amcrest in testing right now, so it was tested with Foscam and Reolink RTSP streams.
I will try to get Amcrest to test and see if there is anything specific to those devices.

Also, what is the device you are using?

Thanks. Its an Amcrest AD110 Doorbell.

@thisisdavidbell What is the Android device you are using?

Fire HD 8 8th generation, reinstalled with Lineage 18.1 on.

It’s obviously not the most powerful setup, but I can run Tiny Cam Pro continuously live without issue. Its not doing as much as HH is of course.