Alarm "Not Supported"

Evening all.

I have recently made a fair few changes to my HA, Tablet(running HomeHabit) and my custom alarm in HA.

I have been using HomeHabit for some time now and never had an issue, always been solid.

I am running this:

It comes up in HomeHabit as “not supported” when selecting an entity.

Which is a custom alarm panel, which is the same as the old alarm I used (BWAlarm).

I’ve upgraded to the latest 1.9 Beta, but still the same. Any ideas?

@bitmass can you provide entity data from developer tools in HA UI? Both entity id and its attributes.


Here you go:

Most likely it is unsupported because of code_format: text, since the app only supports alarms number pin code or no code at all. Did the previous alarm component had different configuration for the alarm code?

Ah that was it, I’ve switched to code_format: number which fixed the issue. I swear I tried that, but obviously not.

Thanks for your help

No problem, glad it works now!
Support for text codes will be added in the future. It is not as often used, so had a lower priority.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.